package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{Han}+`)
var str = `和伟忠一起学习正则
learn regex
2020-05-01`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}