$re = '/(^\d+[A-Z]+)?\d+\D+\K/';
$str = '987ABC11-15; 77; 877; 66-68';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);