using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{0,2}(我说(了)?|(我)?跟你说|(我)?说的是)?请?(你|您)?(快)?(.{0,2}我)?(关闭|忒出|忒粗|关掉|结束|退出|音乐停|停掉|(把)?音乐关|停止|关了|不想听(你|了|你唱(歌|这(.{0,2})?)?|这个)?|(不要|别|不)(唱|放|播|听)(歌|这(.{0,2})?)?)(了)?(行吗|行不|好不|行不行|好吗|好不好|听到(了)?(吗|没|没有)|(你)?还放)?.{0,1}$";
string input = @"我不听了
你别放了
我不想听了
别放了
我要听音乐
我不要听
我不听
别放了啊
跟你说别放了
你别放了听到没
你别放了还放
别放了你
你结束
你别放了啊
快把音乐关上
不想听你唱
不想听你唱歌
别唱了
你别唱了
你别唱了行吗
你别唱了好不好
不要唱了
不要唱歌了
不要唱这个了
别唱这个了
别唱这首歌了
别唱这个歌了
不要放歌了
不想听你唱这个歌了
不想听这个歌
不想听这个了
关闭音响
关闭音乐
关掉音乐
关掉播放器
你关掉音乐
你给我关掉音乐
暂停音乐
把音乐停下来
你把音乐停下来
暂停播放
暂停音乐播放器
给我停下
停下来
音乐停下来
暂停
你给我停下
快给我停下
停
暂停一下呗
停下
唱的真难听
好难听
真难听啊
不好听
不喜欢
真的不喜欢
不喜欢这首歌
不喜欢这个
你唱的太难听了
好难听
不想听音乐
别放音乐
不听音乐
想听周杰伦的歌
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}