use strict;
my $str = '[Example] öäüß asdf 1234 (1aö)
[Red] Panda (It\'s so cute)
[Red] The Panda (It\'s so cute),
[Red] what Panda (It\'s so cute) (not necessary),
[Red] it\'s a Panda (It\'s so cute) (unusual),
[Yellow] Leopard (the big one)
[Yellow] The Leopard (the big one),
[Yellow] what Leopard (the big one) (not needed),
[Yellow] it\'s a Leopard (the big one) (unusual),
[Green] Dragon (Fire? It\'s hot!)
[Green] The Dragon (Fire? It\'s hot!),
[Green] what Dragon (Fire? It\'s hot!) (not usual),
[Green] it\'s a Dragon (Fire? It\'s hot!) (unusual),
[Blue] Snake (zzzZZZzzzZZZ)
[Blue] The Snake (zzzZZZzzzZZZ),
[Blue] what Snake (zzzZZZzzzZZZ) (not beautiful),
[Blue] it\'s a Snake (zzzZZZzzzZZZ) (unusual),
Panda (It\'s so cute)
The Panda (It\'s so cute),
what Panda (It\'s so cute) (not necessary),
it\'s a Panda (It\'s so cute) (unusual),
Leopard (the big one)
The Leopard (the big one),
what Leopard (the big one) (not usual),
it\'s a Leopard (the big one) (unusual),
Dragon (Fire? It\'s hot!)
The Dragon (Fire? It\'s hot!),
what Dragon (Fire? It\'s hot!) (not necessary),
it\'s a Dragon (Fire? It\'s hot!) (unusual),
Snake (zzzZZZzzzZZZ)
The Snake (zzzZZZzzzZZZ),
what Snake (zzzZZZzzzZZZ) (not beautiful),
it\'s a Snake (zzzZZZzzzZZZ) (unusual),
Panda
The Panda,
what Panda (not necessary),
it\'s a Panda (unusual),
Leopard
The Leopard,
what Leopard (not needed),
it\'s a Leopard (unusual),
Dragon
The Dragon,
what Dragon (not usual),
it\'s a Dragon (unusual),
Snake
The Snake ,
what Snake (not beautiful),
it\'s a Snake (unusual),';
my $regex = qr/^(?:\[.*?]\s)?(?<name>.*?)(?:\s\((?:not|unusual)[^()]*\))?,?\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}