re = /\[([^\]]*)\]\((.*?)\)/m
str = 'If the target element is not an `<input>`, `<textarea>` or `[contenteditable]` element, this method throws an error. However, if the element is inside the `<label>` element that has an associated [control](https://developer.mozilla.org/en-US/docs/Web/API/HTMLLabelElement/control), the control will be filled instead.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end