$re = '/Ková(č|cs|c)$/m';
$str = 'Kováč
Kovács
Kovác
Kováčik';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);