$re = '/^(.*?)([A-Z]+)$/m';
$str = 'Ricky RubioPHX
Luka DoncicDAL
Ben SimmonsPHI
Trae YoungATL
Devonte\' GrahamCHA
Damian LillardPOR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);