use strict;
my $str = 'C:\\\\Projects\\\\Ensure_Solution\\\\Assistance\\\\App_WebReferences\\\\Web_ERP_WebService\\\\Web_ERP_Assistant.wsdl
C:\\\\Projects\\\\Ensure_Solution\\\\GD_EServices_Web\\\\App_WebReferences\\\\GD_Eservices_Web_Service\\\\GD_Eservices_Web_Service.wsdl';
my $regex = qr/\\(?:.(?!\\))+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}