import re
regex = re.compile(r"^[1-9]\d*$", flags=re.MULTILINE)
test_str = ("1\n"
"-9\n"
"0\n"
"09\n"
"787\n"
"66")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")