$re = '/([a-zA-Z]+)(.+)(\1)/';
$str = 'Hello_mister,_Hello
ASD___asdfffasd
Whatsup_ddd_sup
HeypalHey______how_ya_how_doin_how';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);