package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)foo.*`)
var str = `fooaaafoooobbbfoo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}