import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?#First, match the protocol)\n"
+ "(?:https?|ftp)://\n"
+ "(?#Next, check for optional username and/or password)\n"
+ "(?#Note: The following two char classes are functionally equivalent)\n"
+ "(?:[\\x21-\\x39\\x3b-\\x3f\\x41-\\x7e]+(?::[!-9;-?A-~]+)?@)?\n"
+ "(?#Next, let's match the domain [with support for Punycode ])\n"
+ "(?:xn--[0-9a-z]+|[0-9A-Za-z_-]+\\.)*(?:xn--[0-9a-z]+|[0-9A-Za-z-]+)\\.(?:xn--[0-9a-z]+|[0-9A-Za-z]{2,10})\n"
+ "(?#Let's match on optional port)\n"
+ "(?::(?:6553[0-5]|655[0-2]\\d|65[0-4]\\d{2}|6[0-4]\\d{3}|[1-5]\\d{4}|[1-9]\\d{1,3}|\\d))?\n"
+ "(?#Next, let's match on the path)\n"
+ "(?:/[\\x21\\x22\\x24\\x25\\x27-x2e\\x30-\\x3b\\x3e\\x40-\\x5b\\x5d-\\x7e]*)*\n"
+ "(?#Next, let's match on an anchor)\n"
+ "(?:\\#[\\x21\\x22\\x24\\x25\\x27-x2e\\x30-\\x3b\\x3e\\x40-\\x5b\\x5d-\\x7e]*)?\n"
+ "(?#Last, but not least, we match on URI params)\n"
+ "(?:\\?[\\x21\\x22\\x24\\x25\\x27-\\x2e\\x30-\\x3b\\x40-\\x5b\\x5d-\\x7e]+=[\\x21\\x22\\x24\\x25\\x27-\\x2e\\x30-\\x3b\\x40-\\x5b\\x5d-\\x7e]*)?\n"
+ "(?#Additional params)\n"
+ "(?:&[\\x21\\x22\\x24\\x25\\x27-\\x2e\\x30-\\x3b\\x40-\\x5b\\x5d-\\x7e]+=[\\x21\\x22\\x24\\x25\\x27-\\x2e\\x30-\\x3b\\x40-\\x5b\\x5d-\\x7e]*)*\n";
final String string = "https://thechildrenareourfuture.org/#SomeRandomAnchorGoesHere\n"
+ "http://user:pass@example.com:8080/omega:33\n"
+ "https://www.google.com:65535/\n"
+ "https://www.google.com:42069/\n"
+ "https://www.google.com:9876/\n"
+ "https://www.google.com:59999/\n"
+ "https://www.google.com:10000/\n"
+ "https://www.google.com:1234/\n"
+ "https://www.google.com:53/\n"
+ "https://www.google.com:123/\n"
+ "https://www.google.com:0/\n"
+ "ftp://username:password@example.com:21/path/here/to/file.tar.gz\n"
+ "http://google.com?redirect=https%3A%2F%2Flocalhost%3A8080&var2=somethingelse\n"
+ "https://john.smith@github.com/UserGroup/repo.git\n"
+ "https://mattermost.com:8065/team/messages/@john.smith\n"
+ "https://punycode.xn--j6w193g\n\n"
+ "smtp://somesite.com/myFile.php\n"
+ "SMTP://SOMESITE.COM/MYFILE.PHP\n"
+ "unknown://somesite.com/fiLeNuM12345.php\n"
+ "//SomeSite.ru/foO.php\n"
+ "://SomeOtherSite.oRg/baRR.php\n\n"
+ "https://_sub1.sub2.sub3.s-u_b4.domain.com\n\n"
+ "http://username:password@subdomain.domain.co.uk/path/to/file.html#Anchor1?key1=value1&key2=value2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}