package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)bob(\s*=\s*)(-?\d+(\.?\d+)?)`)
var str = `bob= 1255`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}