re = /[a-zA-Z0-9_]|\+\+|--|<<|>>|[=+<>^*]=|[\[\](){}.;,!<>+^%]/
str = '++
--
==
<=
>=
^=
*=
+=
[
]
(
)
{
}
.
;
,
!
<
>
+
^
%
<<
>>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end