$re = '/^(?!.*(.)\1\1)(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[.\-!?ยง$%&]).{8,}.*$/m';
$str = 'Foo01-bar
Fooo01-bar
Feo01-bar
Foo01baar
Foo.-baar
Fo0-B4r
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);