package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+:(?:\w+(?:=\w+)?(?:\s+|$))+`)
var str = `name1:A=a name2:B=b name3:C=c d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}