re = /(?<=\s)([Ss]t\.?)\s/
str = 'The St. Leicester Square is located somewhere.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end