package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(`[a-zA-Z0-9_]+)`)
var str = `hasdfk sdlkj 234 g \`lkj \`nmb\`mnb\`mnb
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}