const regex = /^(?=[1-9])\d*\.?\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[1-9])\\d*\\.?\\d+$', 'gm')
const str = `2
22
2222
2.2222
0
1.
0.1
2.4.5
.3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}