import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?:(?<topro>[^)]*?\\bpro\\b)(?:(?<u1> +[^)])(?<l1>[^ )]*))?(?:(?<u2> +[^)])(?<l2>[^ )]*))?(?:(?<u3> +[^)])(?<l3>[^ )]*))?(?:(?<u4> +[^)])(?<l4>[^ )]*))? *|(?<withoutpro>.*?))\\)";
final String string = "4377631753733131 (pro alber con tr33)\n"
+ "886uhghsdfdsfh (pro cios tui tr32)\n"
+ "rtyqrey 6y46457 6372576 (Flrt ghnap tsr)\n"
+ "537657QQRFytyvg (flipzz Reyhdf frfg33)\n\n"
+ "4377631753733131 (pro alber con tr33) (flipzz Reyhdf frfg33) (Foo pro bar pro cios tui tr32)\n"
+ "537657QQRFytyvg (pro foo ))\n\n"
+ "I would like all words after \"pro\" to be capitalized. If \"pro\" is not present, all words in the brackets must be lowercase, for have :\n\n"
+ "4377631753733131 (pro Alber Con Tr33)\n"
+ "886uhghsdfdsfh (pro Cios Tui Tr32)\n"
+ "rtyqrey 6y46457 6372576 (flrt ghnap tsr)\n"
+ "537657QQRFytyvg (flipzz reyhdf frfg33)";
final String subst = "(${topro}\\U${u1}\\L${l1}\\U${u2}\\L${l2}\\U${u3}\\L${l3}\\U${u4}\\L${l4}\\L${withoutpro})\\E";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}