use strict;
my $str = 'https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/52208-dampflokomotive-br-80-db.html
https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/36086-dampflokomotive-44-0104-8-dr.html
https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/70038-dampflokomotive-56-2009-1-dr.html
https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/70040-dampflokomotive-231-e-34-sncf.html
https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/7110002-dampflokomotive-tkt-21-pkp.html
https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/70047-dampflokomotive-521591-obb.html
https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/70046-dampflokomotive-br-8970%e2%80%9375-dr.html
https://www.roco.cc/rde/produkte/lokomotiven/dampflokomotiven/73030-dampflokomotive-rh-86-obb.html
https://www.roco.cc/rde/produkte/lokomotiven/elektrolokomotiven/60226-elektrolokomotive-rh-372-cd-cargo.html
https://www.roco.cc/rde/produkte/lokomotiven/elektrolokomotiven/60239-elektrolokomotive-s-4992002-csd.html
https://www.roco.cc/rde/produkte/lokomotiven/elektrolokomotiven/60974-elektrolokomotive-193-759-8-ns.html
https://www.roco.cc/rde/produkte/lokomotiven/elektrolokomotiven/60492-elektrolokomotive-1116-182-7-bundesheer-obb.html
https://www.roco.cc/rde/produkte/lokomotiven/elektrolokomotiven/60921-elektrolokomotive-litra-eb-3202-dsb.html
https://www.roco.cc/rde/produkte/lokomotiven/elektrolokomotiven/70618-elektrolokomotive-cc-6574-sncf.html
https://www.roco.cc/rde/produkte/lokomotiven/elektrolokomotiven/70653-elektrolokomotive-e-186-012-ns.html
https://www.roco.cc/rde/home-neuheiten/70673-elektrolokomotive-el-18-2260-go-ahead.html
';
my $regex = qr/https://www\.roco\.cc/rde/(produkte/([A-z]*)|home-neuheiten)/([A-z]*)/*([0-9]{5,})-([A-z]*)-(?P<baureihe>el|e|cc|litra-eb|s|br|tkt|rh)*(?P<number>[e%0-9\-]*)-([a-z\-]*).html/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}