re = /^"(\d{1,2})(\/)(\d{2})(\/)(\d{4})(.*)\n(.*)\n(.*\,"")/m
str = '"8/20/2023","SQ *CHRIS- SAL","SQ *CHRIS- SAL","130.00","debit","Entertainment","CC Apple Card","",""
"8/20/2023","CHEVRON","CHEVRON","81.79","debit","Gas & Fuel","CC Apple Card","",""
"8/19/2023","DD DOORDASH 855-973-1040 CA
APPLE PAY","DD DOORDASH 855-973-1040 CA
APPLE PAY","64.38","debit","Food Delivery","CC Discover","",""
"8/19/2023","SP PEACHY K","SP PEACHY K","65.00","debit","Restaurants","CC Apple Card","",""
"8/19/2023","Cash App","Cash App","200.00","debit","Transfer","CHECKING","",""
"8/18/2023","DD DOORDASH 855-973-1040 CA
APPLE PAY","DD DOORDASH 855-973-1040 CA
APPLE PAY","10.15","debit","Food Delivery","CC Discover","",""
"8/18/2023","DD DOORDASH 855-973-1040 CA
APPLE PAY","DD DOORDASH 855-973-1040 CA
APPLE PAY","45.56","debit","Food Delivery","CC Discover","",""
"8/18/2023","GAS","GAS","18.69","debit","Utilities","CHECKING CapOne","",""
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end