re = /^(?:(?:([<>])(?!.*\1))?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)(?:[<>]?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)?$/m
str = '<alpha<bravo
>alpha>bravo
alpha>bravo
alpha
alphaBravo
alphaBravoCharlie
>alpha
<alpha
>alpha+10
<alpha+10
>alpha+1.5
<alpha+1.5
>alpha-10
>alpha-10
>alpha-1.5
>alpha-1.5
>alpha+10em
<alpha+10em
>alpha+1.5em
<alpha+1.5em
>alpha-1.5em
>alpha-1.5em
alpha-50em<delta-100em
alpha-50em<delta+100em
>alpha-50em<delta+100em
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end