re = /(?![\s,])(?:[^:]*:){3}\S*(?![^,])/m
str = 'Checkers, etc:Blue::C, Backgammon, I say:Green::Pepsi:P, Chess, misc:White:Coke:Florida:A, :::U'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end