# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<method>https?|git|ssh)(?::\/\/(?:\w+@)?|@)(?P<provider>.*?)(?:\.org|\.com)(?:\/|:)(?P<handle>(?P<owner>.+?)\/(?P<repo>.+?))(?:\.git|\/)?$"
test_str = ("git@github.com:cualbondi/web.git\n"
"git@gitlab.com:marcosfede/celerative-bluechip-frontend.git\n"
"git@bitbucket.org:account_name/repo_name.git\n\n"
"https://github.com/cualbondi/web.git\n"
"https://github.com/cualbondi/web\n"
"https://github.com/cualbondi/web/\n"
"https://gitlab.com/marcosfede/celerative-bluechip-frontend.git\n"
"https://your_username@bitbucket.org/<account_name>/<repo_name>.git\n\n"
"ssh://git@bitbucket.org/<account_name>/<repo_name>.git\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.