const regex = /^(?!NOT FOUND \*\*\*\*\* ).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!NOT FOUND \\*\\*\\*\\*\\* ).*$', 'gm')
const str = `a68ebf048cb21948ae814f88f8573267 *Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part23.rar
143bc5637fca8831800682da24fabdbe *Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part24.rar
eecbe9a184700963a09a3dc6486d1f72 *Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part25.rar
51f6341b48d44788775ee676e9fd106a *Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e03.Bastille.Day.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.sfv
NOT FOUND ***** Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part01.rar
NOT FOUND ***** Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part02.rar
NOT FOUND ***** Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part03.rar
NOT FOUND ***** Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part04.rar
NOT FOUND ***** Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part05.rar
NOT FOUND ***** Torrented Movies\\Battlestar Galactica\\Season 1\\Video Files\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL\\Battlestar.Galactica.s01e04.Act.Of.Contrition.iNTERNAL.WS.DVDRip.XviD-MEDiEVAL.part06.rar
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);