re = /(?:[a-z]*([a-z])[^a-z]+(?=\1))+[a-z]+/mi
str = 'word !dark,123 king... glow__we 3end hello bye low3 ?wing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end