$re = '~<userFields>.*</userFields>~msU';
$str = '<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);