import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\(?([\\d \\-\\)\\–\\+\\/\\(.]+){5}\\)?([ .\\-–\\/]?)([\\d]+))$";
final String string = "US (North American) Phone Numbers\n"
+ "1-800-123-4567\n"
+ "(123)456-7890\n"
+ "1234567890\n"
+ "123-456-7890\n"
+ "123.456.7890\n"
+ "123 456 7890\n"
+ "(123) 456 7890\n"
+ "UK Phone Numbers\n"
+ "+447222555555\n"
+ "+44 7222 555 555\n"
+ "(0722) 5555555 #2222\n"
+ "French Phone Numbers\n"
+ "0123456789\n"
+ "01 23 45 67 89\n"
+ "01.23.45.67.89\n"
+ "0123 45.67.89\n"
+ "0033 123-456-789\n"
+ "+33-1.23.45.67.89\n"
+ "+33 – 123 456 789\n"
+ "+33(0) 123 456 789\n"
+ "+33 (0)123 45 67 89\n"
+ "+33 (0)1 2345-6789\n"
+ "+33(0) – 123456789\n"
+ "German Phone Numbers\n"
+ "(06442) 3933023\n"
+ "(02852) 5996-0\n"
+ "(042) 1818 87 9919\n"
+ "06442 / 3893023\n"
+ "06442 / 38 93 02 3\n"
+ "06442/3839023\n"
+ "042/ 88 17 890 0\n"
+ "+49 221 549144 – 79\n"
+ "+49 221 – 542194 79\n"
+ "+49 (221) – 542944 79\n"
+ "0 52 22 – 9 50 93 10\n"
+ "+49(0)121-79536 – 77\n"
+ "+49(0)2221-39938-113\n"
+ "+49 (0) 1739 906-44\n"
+ "+49 (173) 1799 806-44\n"
+ "0214154914479\n"
+ "02141 54 91 44 79\n"
+ "01517953677\n"
+ "+491517953677\n"
+ "015777953677\n"
+ "02162 – 54 91 44 79\n"
+ "(02162) 54 91 44 79\n"
+ "Chinese Phone Numbers\n"
+ "0936-4211235\n"
+ "89076543\n"
+ "010-12345678-1234\n"
+ "Chinese Mobile Phone Numbers\n"
+ "008618311006933\n"
+ "+8617888829981\n"
+ "1911925564\n"
+ "India Phone Numbers\n"
+ "03595-259506\n"
+ "03592 245902\n"
+ "03598245785\n"
+ "9775876662\n"
+ "0 9754845789\n"
+ "0-9778545896\n"
+ "+91 9456211568\n"
+ "91 9857842356\n"
+ "919578965389\n"
+ "Brazilian Phone Numbers\n"
+ "(12) 123 1234\n"
+ "(01512) 123 1234\n"
+ "(0xx12) 1234 1234\n"
+ "Australian Phone Numbers\n"
+ "0732105432\n"
+ "1300333444\n"
+ "131313\n"
+ "Dutch Phone Numbers\n"
+ "+31235256677\n"
+ "+31(0)235256677\n"
+ "023-5256677\n"
+ "Sweden Phone Numbers\n"
+ "+46 8 123 456 78\n"
+ "08-123 456 78\n"
+ "0123-456 78\n"
+ "thx to https://regexpattern.com/phone-number/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}