# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=.)[^@\n](?=[^@\n]*?@)|(?:(?<=@.)|(?!^)\G(?=[^@\n]*$)).(?=.*[^@\n]\.)/*/gm;t' <<< "john.doe@example.en.com
foo@bar.com
foo-and.more!here@bar.com
fo@bar.com
f@bar.com"