import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d) (\\S+) (\\d{2} \\w{3} \\d{4}) (.*)\\s+-\\s(Dkt\\S+)\\s*(.*?)\\s*(\\$\\d+(?:\\.\\d+)?)\\.?\\s*$";
final String string = "1 240R 15 Apr 2021 240 Litre Sulo Bin Recycling - Dkt#11053610 O/N: ONE DENTAL $10.00\n"
+ "1 1.5cm 06 Apr 2021 1.5m Co-Mingle Recycling Bin - Dkt#11028471 $18.00.\n"
+ "1 1.5m 12 Apr 2021 Service 1.5m Front Lift bin - Dkt#11028421 $24.00\n"
+ "1 660 14 Apr 2021 660L Rear Lift Bin - Dkt#11156377 O/N: YOUR CAR SOLD $22.50";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}