using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z\d]*";
string input = @"abcdk436685
sdlisanrgl
sgvjsgvb
2345678990
#$%&*$#^#$&%^$*&";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}