$re = '/^.{10,}$/m';
$str = 'abcdk436685
sdlisanrgl
sgvjsgvb
2345678990
#$%&*$#^#$&%^$*&
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);