re = /^[\w]{5,10}$/m
str = 'abcdk436685
sdlisanrgl
sgvjsgvb
2345678990
#$%&*$#^#$&%^$*&
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end