$re = '/((?:\(\d{3}\)|\d{3})?(?:\s|\s?-\s?)?\d{3}(?:\s|\s?-\s?)?\d{4})/m';
$str = '1234567890\', \'202-456-3456\', \'(202)-456-3456adsd\', \'(202)-456- 4567\', \'1234564567(dads)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);