const regex = /^\$ABC(?!02)[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$ABC(?!02)[0-9]+$', 'gm')
const str = `\$ABC01
\$ABC02
\$ABC03
\$ABC04
\$ABC05
\$ABC0210`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}