# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" *(?:.*\S.*\n)+\n? *: +(?:.|\n)+?(?:\n{2,}(?=\S)(?! *: +)(?! *(?:\S.*\n)+?\n? *: +)|$)"
test_str = ("=== Single <dt> and <dd>\n\n"
"GitHub\n"
": a site where over 73 million developers shape the future of software, together\n\n"
"=== Multiple <dt>-<dd> group\n\n"
"Firefox\n"
": a free, open source, cross-platform, graphical web browser developed by the Mozilla Corporation and hundreds of volunteers\n\n"
"MDN\n"
": provides information about Open Web technologies including HTML, CSS, and APIs for both Web sites and progressive web apps\n\n"
"=== Single <dt> with multiple <dd>s\n\n"
"Apple\n"
" : an American multinational technology company that specializes in consumer electronics, computer software and online services.\n"
" : an edible fruit produced by an apple tree\n\n"
"=== Multiple <dt>s\n\n"
"Windows\n"
"Microsoft Windows\n"
"Win\n"
": a group of several proprietary graphical operating system families, all of which are developed and marketed by Microsoft\n\n"
"=== separated by blank lines\n\n"
"Solaris\n\n"
": a 1961 science fiction novel by Polish writer Stanisław Lem\n\n\n\n"
": a proprietary Unix operating system originally developed by Sun Microsystems\n\n"
"=== <dd>s with inline breaks\n\n"
"Oracle\n"
": an American multinational computer technology\n"
"corporation headquartered in Austin, Texas\n\n"
": the priest or priestess uttering the prediction,\n"
"may also refer to the site of the oracle\n\n"
"===\n\n"
"😂\n"
": 😂 face with tears of joy\n\n"
"===\n\n"
"Term 1\n\n"
": This is a definition with two paragraphs. Lorem ipsum \n"
" dolor sit amet, consectetuer adipiscing elit. Aliquam \n"
" hendrerit mi posuere lectus.\n\n"
" Vestibulum enim wisi, viverra nec, fringilla in, laoreet\n"
" vitae, risus.\n\n"
": Second definition for term 1, also wrapped in a paragraph\n"
" because of the blank line preceding it.\n\n"
"Term 2\n\n"
": This definition has a code block, a blockquote and a list.\n\n"
" code block.\n\n"
" > block quote\n"
" > on two lines.\n\n"
" 1. first list item\n"
" 2. second list item")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.