re = /(?<=HREF=").*?"/m
str = '<DT><A HREF="https://cheatsheetseries.owasp.org/cheatsheets/Clickjacking_Defense_Cheat_Sheet.html" ADD_DATE="1567455957">Clickjacking Defense ยท OWASP Cheat Sheet Series</A>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end