import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[[0-9a-fA-F]{6}\\])?(.+?)(?=\\[[0-9a-fA-F]{6}\\]|$)";
final String string = "[00B800][!] Green - [004DB8] Blue does not match!!\n\n"
+ "[FFFFff][!] White\n\n"
+ "[e60000][!] Red\n\n"
+ "123456\n\n"
+ "Test string, another test abcdef";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}