const regex = /^(?=.{8,9}$)[NVQWST][A-Z\s]{1,3}[0-9]{1,6}(?:(?<=^.{8})[A-Z])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{8,9}$)[NVQWST][A-Z\\s]{1,3}[0-9]{1,6}(?:(?<=^.{8})[A-Z])?$', 'gm')
const str = `NABC1234A
NABC1234
NABC123A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}