$re = '/(?<=-)\D+(?=\s\()/m';
$str = '01-Q2-Locate of este (TT) 01-Q2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);