// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+)@(.+?)\.((?:(?:co|more)\.)?[^.]+)$").unwrap();
let string = "serebro@gmail.com
serebro@gmail.co.uk
serebro@another.gmail.co.uk
sr@text.here.co.and.more.here";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}