$re = '/,"?(.*[^"]|)"?,/m';
$str = '"0x00000000","What do you want to eat? fish, meat or eggs?",""
"0x00030002","What do you want to eat?",""
0x00000000,What do you want to eat? fish, meat or eggs?,
0x00030002,What do you want to eat?,
"0x00000000","What do you want to eat? fish, meat or eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
0x00030002,,
"0x00030002","",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);