$re = '/^(?!\d+$)\w+\S+/m';
$str = '1234567
&123abc
hello
helloworld8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);