package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\/u\/([^/\s]+)\/`)
var str = `/u/some_user/create/initial
/u/some_user/create
/u/some_user`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}