Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
@"
^[a-z][a-z0-9]*(([A-Z]{1,3}[a-z0-9]+)*[A-Z]{0,3}|([a-z0-9]+[A-Z]{1,3})*|[A-Z]{1,3})$
"
gm
Input 1
1
New
snake_case PascalCase 2PascalCase streamIOIO gREATERDtha modeADFAFdsADFads aBabcABCDabcABC camelCa_1 contextHTMLParser hELLO modeADFdsADFads streamIO aBCabcABCabcA aBCabcA aabc123 aabcABC ab abc abcd abcde deviceSNS pathASNs dscpCP awsVPC deviceID camelCasecamelCasecamelCasecamelCasecamelCasecamelCase gREA1 gREAt gREAtREAt cP3 a1 aABC a123 modeADFsADFads a1G aG a modeADFads camelCase lThan30DaysCount lessThan30DaysCount lessThan30DaysCountA greaterThan30LessThan60DaysCount greaterThan60LessThan90DaysCount greaterThan90DaysCount pascalCase pascal2Case pascalCaseA pascal2CaseA modeA mode2A mode2A2 mode2A2A createAMode createBMode madeEasy wonderFul andMe htmlParser h aaA camel01C camel01c01 camel01C01 camel01CC01 camel0a1c1 camel0a1C1 camel0ac1b1C1 camelC camelC1 camelCA camelCa1 ibsReleaseTestVerificationRegressionSuite ibsReleaseTestVerificationRegressioNSuite ibsReleaseTestVerificationRegressioN xmlHttpRequest newCustomerId innerStopwatch supportsIpv6OnIos youTubeImporter youtubeImporter affine3D