using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?aaaaaaaaaaaaaaaaaaaa";
string input = @"aaaaaaaaaaaaaaaaaaaa";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}