using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^uuid.*\n";
string substitution = @"";
string input = @"uuid: d0856f49-30d3-4448-8fde-1e3373821bd9
langcode: en
status: true
dependencies: { }
_core:
default_config_hash: zglzjmYxi0G0ag9MZ02y0LSJOdpWRwJxyP_OvFojFyo
id: basic
label: 'Basic Block'
revision: 0
description: 'A basic block contains a title and a body.'
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}