#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:(?i:\bTRAVESSA\b|\bACAMPAMENTO\b|\bACESSO\b|\bACUDE\b|\bADRO\b|\bAEROPORTO\b|\bAFLUENTE\b|\bAGLOMERADO\b|\bAGROVILA\b|\bALAGADO\b|\bALAMEDA\b|\bALDEIA\b|\bALEIA\b|\bALTO\b|\bANEL\b|\bANTIGA\b|\bANTIGO\b|\bAREA\b|\bAREAL\b|\bARRAIAL\b|\bARROIO\b|\bARTERIA\b|\bASSENTAMENTO\b|\bATALHO\b|\bATERRO\b|\bAUTODROMO\b|\bAVENIDA\b|\bAV\b|\bBAIA\b|\bBAIRRO\b|\bBAIXA\b|\bBAIXADA\b|\bBAIXADAO\b|\bBAIXAO\b|\bBAIXO\b|\bBALAO\b|\bBALNEARIO\b|\bBARRA\b|\bBARRAGEM\b|\bBARRANCA\b|\bBARRANCO\b|\bBARREIRO\b|\bBARRO\b|\bBECO\b|\bBEIRA\b|\bBEIRADA\b|\bBELVEDERE\b|\bBLOCO\b|\bBOCAINA\b|\bBOQUEIRAO\b|\bBOSQUE\b|\bBOULEVARD\b|\bBREJO\b|\bBURACO\b|\bCABECEIRA\b|\bCACHOEIRA\b|\bCACHOEIRINHA\b|\bCAIS\b|\bCALCADA\b|\bCALCADAO\b|\bCAMINHO\b|\bCAMPO\b|\bCANAL\b|\bCANTEIRO\b|\bCAPAO\b|\bCAPOEIRA\b|\bCARTODROMO\b|\bCENTRAL\b|\CENTRO\b|\bCERCA\b|\bCERRADO\b|\bCERRO\b|\bCHACARA\b|\bCHAPADA\b|\bCHAPADAO\b|\bCHARCO\b|\bCIDADE\b|\bCIRCULAR\b|\bCOHAB\b|\bCOLINA\b|\bCOLONIA\b|\bCOMUNIDADE\b|\bCONDOMINIO\b|\bCONJUNTO\b|\bCONTINUACAO\b|\bCONTORNO\b|\bCORREDOR\b|\bCORREGO\b|\bCOSTA\b|\bCOXILHA\b|\bCRUZAMENTO\b|\bDESCIDA\b|\bDESVIO\b|\bDIQUE\b|\bDISTRITO\b|\bDIVISA\b|\bDIVISAO\b|\bDIVISOR\b|\bEDF\b|\bEDIFICIO\b|\bEIXO\b|\bELEVADO\b|\bENCOSTA\b|\bENGENHO\b|\bENSEADA\b|\ENTRADA\b|\bENTREPOSTO\b|\bENTRONCAMENTO\b|\bESCADA\b|\ESCADAO\b|\bESCADARIA\b|\bESCADINHA\b|\bESPIGAO\b|\bESPLANADA\b|\bESQUINA\b|\bESTAÇÃO\b|\bESTACIONAMENTO\b|\bESTADIO\b|\bESTANCIA\b|\bESTRADA\b|\bEXTENSÃO\b|\bFAIXA\b|\bFAVELA\b|\bFAZENDA\b|\bFEIRA\b|\bFERROVIA\b|\bFINAL\b|\bFLORESTA\b|\bFOLHA\b|\bFONTE\b|\bFORTALEZA\b|\bFORTE\b|\bFREGUESIA\b|\bFUNDOS\b|\bFURO\b|\bGALERIA\b|\bGAMELEIRA\b|\bGARIMPO\b|\bGLEBA\b|\bGRANJA\b|\bGROTA\b|\bHABITACIONAL\b|\bHARAS\b|\bHIPODROMO\b|\bHORTO\b|\bIGARAPE\b|\bILHA\b|\bINVASÃO\b|\bJARDIM\b|\bJARDINETE\b|\bLADEIRA\b|\bLADO\b|\bLAGO\b|\bLAGOA\b|\bLAGOINHA\b|\bLAMEIRA\b|\bLARGO\b|\bLATERAL\b|\bLEITO\b|\bLIGAÇÃO\b|\bLIMEIRA\b|\bLIMITE\b|\bLIMITES\b|\bLINHA\b|\bLOTE\b|\bLOTEAMENTO\b|\bLUGAREJO\b|\bMALOCA\b|\bMANANCIAL\b|\bMANGUE\b|\bMARGEM\b|\bMARGENS\b|\bMARGINAL\b|\bMARINA\b|\bMATA\b|\bMATO\b|\bMODULO\b|\bMONTE\b|\bMORRO\b|\bMURO\b|\bNUCLEO\b|\bOCA\b|\bOLEODUTO\b|\bOLHO\b|\bOLHOS\b|\bORLA\b|\bPAÇO\b|\bPALAFITA\b|\bPANTANO\b|\bPARADA\b|\bPARADOURO\b|\bPARALELA\b|\bPARQUE\b|\bPARTICULAR\b|\bPASSAGEM\b|\bPASSARELA\b|\bPASSEIO\b|\bPASSO\b|\bPASTO\b|\bPÁTIO\b|\bPAVILHÃO\b|\bPEDRA\b|\bPEDRAS\b|\bPEDREIRA\b|\bPENEDO\b|\bPENHASCO\b|\bPERIMETRAL\b|\bPERIMETRO\b|\bPERTO\b|\bPLANALTO\b|\bPLATAFORMA\b|\bPONTA\b|\bPONTE\b|\bPONTO\b|\bPORTO\b|\bPOSTO\b|\bPOVOADO\b|\bPRACA\b|\bPRAIA\b|\bPROJECAO\b|\bPROJETADA\b|\bPROJETO\b|\bPROLONGAMENTO\b|\bPROPRIEDADE\b|\bPROXIMO\b|\bQUADRA\b|\bQUARTEIRAO\b|\bQUILOMBO\b|\bQUILOMETRO\b|\bQUINTA\b|\bQUINTAS\b|\bRAMAL\b|\bRAMPA\b|\bRANCHO\b|\bRECANTO\b|\bREGIAO\b|\bREPRESA\b|\bRESIDENCIAL\b|\bRETA\b|\bRETIRO\b|\bRETORNO\b|\bRIACHAO\b|\bRIACHO\b|\bRIBANCEIRA\b|\bRIBEIRAO\b|\bRINCAO\b|\bRIO\b|\bROCHA\b|\bROCHEDO\b|\bRODOVIA\b|\bROTATORIA\b|\bROTULA\b|\bRUA\b|\bR\b|\bRUELA\b|\bSACO\b|\bSAIDA\b|\bSANGA\b|\bSEDE\b|\bSERINGAL\b|\bSERRA\b|\bSERTAO\b|\bSERVIDAO\b|\bSETA\b|\bSETOR\b|\bSITIO\b|\bSOPE\b|\bSUBIDA\b|\bSUPERQUADRA\b|\bTAPERA\b|\bTERMINAL\b|\bTERRA\b|\bTERRENO\b|\bTERRENOS\b|\bTRANSVERSAL\b|\bTRAVESSA\b|\bTRAVESSAO\b|\bTRAVESSIA\b|\bTRECHO\b|\bTREVO\b|\bTRILHA\b|\bTRILHO\b|\bTRILHOS\b|\bTRINCHEIRA\b|\bTUNEL\b|\bUNIDADE\b|\bUSINA\b|\bVALA\b|\bVALAO\b|\bVALE\b|\bVARGEM\b|\bVARIANTE\b|\bVARZEA\b|\bVELODROMO\b|\bVEREDA\b|\bVERTENTE\b|\bVIA\b|\bVIADUTO\b|\bVICINAL\b|\bVIELA\b|\bVILA\b|\bVILAREJO\b|\bVOLTA\b|\bZONA\b)\.?)(?:(?:(?:[ \t\x0B\f\r]+\S+)))\b(?:(?:[^\.](?:.+?\. ))|(?:[^\.](?:.+?\.)))" & @CRLF & _
""
Local $sString = "Rua 15 de novembro de São Paulo comprou uma jaqueta amarela que foi lavada." & @CRLF & _
"Travessa São João ." & @CRLF & _
"" & @CRLF & _
"Avenida das acácia, 999, Oitavão, São Paulo, SP 91110000." & @CRLF & _
"Av 11 De Fevereiro 1 Sala 2 Centro, São Paulo SP 91110000." & @CRLF & _
"" & @CRLF & _
"Avenida das acácia, 999, São Paulo, Oitavão, Brasil." & @CRLF & _
"R. 11 de Fevereiro está na direita do condado de berkley." & @CRLF & _
"Avenida Paulista, nº 550, São Paulo, cep: 95100 000, Brasil." & @CRLF & _
"Avenida Lins de Vasconcelos, 234; Avenida Paulista, 316, apartamento 13." & @CRLF & _
"" & @CRLF & _
"Conforme Av. Do Cadilac, 666 - Bairro Alegre, 12345-678, Cidade Alegre, SP." & @CRLF & _
"" & @CRLF & _
"av do Cadilac, 666 - bairro Alegre, 12345-678, Cidade Alegre, SP" & @CRLF & _
"" & @CRLF & _
"Rio de Janeiro adsasd asdad. rio 123." & @CRLF & _
"" & @CRLF & _
"Otávio comprou na galeria de endereço av 10 De Fevereiro, São Paulo SP 11110000 e depois seguiu com as compras na cidade de Gramado procurando um novo enderço Rua Getulio Vargas." & @CRLF & _
"" & @CRLF & _
"Juliana Emanuela da Luz Souza portadora do CPF 008.543.213-30, recebe um salário de 1500,30 reais." & @CRLF & _
" Atualmente mora na Avenida dos logradouros 467 número 14, São Leopoldo e, por 40 horas é empregada na empresa Cristal Serrano com o CNPJ 13.123.321/4133-44. " & @CRLF & _
"De acordo com o seu cadastro, possui o seguinte telefone de contato +55 (54) 99166-6508." & @CRLF & _
"Conforme vem a solicitar a Receita Federal é indicado que por meio deste documento disposto para o contribuinte de RG 183654527, uma multa no valor de 54 dólares seja cobrada por não possuir a CNH de número 10234556378 e carteira de trabalho 123 45678 91 0 validadas de acordo com a lei atribuída na tribuna com o endereço Avenida Júlio de Castilhos número 45000. " & @CRLF & _
"Conforme sentenciado pelo juiz Carlos Romano de Freitas Pereira da Silva. As informações do indivíduo estão dispostas no email descubraoproblema@sindicato.com.br. " & @CRLF & _
"Para fazer acesso ao email é necessário configurar o computador com que fique com o IPV4 utilizado seja 112.128.52.10 e o IPV6 deve ser 2001:ca8:0:1fe1::200. Para acessar a conta é necessário que o contribuinte utilize o número disposto na carteira de trabalho sendo esta 123.45678.91-0 e o número do passaporte sendo este CS123456. É importante que o usuário comprove os dados utilizando o número do título de eleitor 1234 5678 9101. O valor final que deverá ser pago deve corresponder a um valor simbólico de 7.891,12 brl. " & @CRLF & _
"É Importante destacar a necessidade de mostrar o RG 123456789 e a CNH 12345678910." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")