$re = '/(I?II?III?)*/m';
$str = 'CI101
CS164
ENGL101
I-
III-
MATH116
PSY101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);